トップページ > 記事閲覧
Ver3.19bのコンパイルエラー
名前:チップ 日時: 2018/04/01 20:31

いつもお世話になっております。 早速DXライブラリ(Ver3.19b)ののプロジェクトをダウンロードさせて頂いて ソースからコンパイルしたところ、下記のエラーが出ました。 1>DxGraphics.cpp(28630): error C2660: 'DxLib::ConvString': 関数に 5 個の引数を指定できません。 どうもConvString関数に対してこの行の部分だけ引数が足りないようです。 他のところのように引数の二つ目に -1 を付け加える感じでしょうか…? 対処方法を教えて頂けると助かります。 よろしくお願い致します。
メンテ

Page: 1 |

Re: Ver3.19bのコンパイルエラー ( No.1 )
名前:管理人 日時:2018/04/03 00:34

すみません、DX_NON_MOVIE を有効にした状態だとご指摘の箇所でコンパイルエラーが発生するようになっていました お察しの通り、第二引数に -1 を加えればコンパイルが成功するようになります 一応こちらにも修正版のソースをアップしましたので、よろしければお使いください m(_ _;m // ソース http://dxlib.o.oo7.jp/temp/DxLibMakeTest.zip
メンテ
Re: Ver3.19bのコンパイルエラー(解決) ( No.2 )
名前:チップ 日時:2018/04/02 08:22

早速のご対応、ありがとうございます! 感謝します。
メンテ
Re: Ver3.19bのコンパイルエラー ( No.3 )
名前:チップ(解決) 日時:2018/04/02 08:23

解決済み
メンテ
Re: Ver3.19bのコンパイルエラー ( No.4 )
名前:nsawa 日時:2018/04/02 09:16

横から失礼します。 私も本日「http://dxlib.o.oo7.jp/temp/DxLibMakeTest.exe」をダウンロードさせて頂いたのですが、「Ver 3.19a」となっており、前のバージョンのようでした。 最新バージョンのソースは、「http://dxlib.o.oo7.jp/temp/DxLibMakeTest.zip」でしょうか? (以前と拡張子が変わったみたい?) 以上失礼しました。
メンテ
Re: Ver3.19bのコンパイルエラー ( No.5 )
名前:管理人 日時:2018/04/03 00:56

> nsawaさん > 最新バージョンのソースは、「http://dxlib.o.oo7.jp/temp/DxLibMakeTest.zip」でしょうか? (以前と拡張子が変わったみたい?) すみません、その通りです、最新バージョンのソースは DxLibMakeTest.zip となります、ご指摘ありがとうございます orz No.1 のご返信のパスも DxLibMakeTest.zip に修正しました m(_ _;m > チップさん すみません、DxLibMakeTest.exe ではなく、正しくは DxLibMakeTest.zip でした、 もし DxLibMakeTest.exe をダウンロードされてしまっていましたら、お手数で申し訳ありませんが こちらの DxLibMakeTest.zip をダウンロードしてください m(_ _;m // ソース http://dxlib.o.oo7.jp/temp/DxLibMakeTest.zip
メンテ

Page: 1 |

題名
名前
コメント
パスワード (記事メンテ時に使用)

   クッキー保存